Chinaunix首页 | 论坛 | 博客
  • 博客访问: 1238126
  • 博文数量: 252
  • 博客积分: 1218
  • 博客等级: 少尉
  • 技术积分: 2808
  • 用 户 组: 普通用户
  • 注册时间: 2011-06-19 02:33
文章分类

全部博文(252)

文章存档

2019年(3)

2018年(10)

2016年(1)

2015年(20)

2014年(115)

2013年(46)

2012年(37)

2011年(20)

分类:

2011-08-17 22:23:50

安装这次Fedora 14时,竟然饶不过去,还是提示 。。。/usr/src/include....头文件不匹配的问题。

搜索了资料,见http://www.linuxidc.com/Linux/2011-04/34342p2.htm

 

的确如此:“。。。vmware读取的版本,UTS_RELEASE!我们往 linux/version.h 。。。”,但按照资料中的方法处理仍然不成功。

检查vmware读取的版本,读出的是"2.6.35.11",我的定义是:#define UTS_RELEASE "2.6.35.11"

 

 

所以这样解决:


我用"uname -a"查看内和版本是:"2.6.35.11-83.fc14.i686",

查看/usr/src/kernels/2.6.35.6-45.fc14.i686/include/linux/version.h:

#defineLINUX_VERSION_CODE 132630
#defineKERNEL_VERSION(a,b,c)(((a)%26lt;%26lt;16)+((b)%26lt;%26lt;8)+(c))

 

在最上面加入一行#define UTS_RELEASE "2.6.35.11-83.fc14.i686":

#define UTS_RELEASE "2.6.35.11-83.fc14.i686"

#defineLINUX_VERSION_CODE 132630
#defineKERNEL_VERSION(a,b,c)(((a)%26lt;%26lt;16)+((b)%26lt;%26lt;8)+(c))

 

保存,重新安装。

我又没安装成功,不知道为什么晕

阅读(1263) | 评论(2) | 转发(0) |
给主人留下些什么吧!~~

xuebabybaby2011-08-22 16:12:28

建议去看一下我另一篇vm6.5下fedora 6 的VMtools的安装

xuebabybaby2011-08-22 16:12:25

建议去看一下我另一篇vm6.5下fedora 6 的VMtools的安装

评论热议
请登录后评论。

登录 注册