Chinaunix首页 | 论坛 | 博客
  • 博客访问: 4501476
  • 博文数量: 2760
  • 博客积分: 1021
  • 博客等级: 中士
  • 技术积分: 4091
  • 用 户 组: 普通用户
  • 注册时间: 2012-03-11 14:14
文章分类

全部博文(2760)

文章存档

2019年(1)

2017年(84)

2016年(196)

2015年(204)

2014年(636)

2013年(1176)

2012年(464)

分类: 云计算

2014-03-31 09:00:42

原文地址:hadoop的0.23.*配置问题 作者:1012191556

hadoop0.23.*的配置比之前的版本配置有好多的不同,不能再像以前一样来配置了,基本配置如下http://www.myexception.cn/open-source/1276103.html
当你如上面配置完以后也许会出好多错误(版本越高,错误越多,但是你能根据错误提示来解决)
例如 输入:hadoop namenode -format (在hadoop主文件下)
      错误:DEPRECATED: Use of this script to execute hdfs command is deprecated.
Instead use the hdfs command for it.
      解决办法:hdfs namenode -format
      可能原因:hadoop已经去掉hadoop进行国际化换为:hdfs
不过当你再次格式化hadoop时 就可以用 hadoop namenode -format了
      输入:./start-all.sh (要在sbin目录下)
      错误:This script is Deprecated. Instead use start-dfs.sh and start-mapred.sh
      解决办法:./start-dfs.sh ;./start-mapred.sh
      可能原因:用./start-dfs.sh ;./start-mapred.sh替换了./start-all.sh
阅读(548) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~
评论热议
请登录后评论。

登录 注册