Chinaunix首页 | 论坛 | 博客
  • 博客访问: 1070709
  • 博文数量: 228
  • 博客积分: 474
  • 博客等级: 下士
  • 技术积分: 1930
  • 用 户 组: 普通用户
  • 注册时间: 2010-03-19 18:40
文章分类

全部博文(228)

文章存档

2019年(3)

2018年(12)

2017年(13)

2016年(11)

2015年(55)

2014年(75)

2013年(39)

2012年(2)

2011年(18)

我的朋友

分类: Java

2017-03-24 10:20:03

环境

    eclipse 4.3.0
    maven 3.0.4
    m2e 1.4.0
    

出现场景

    以前的老项目,在我的环境(我的环境较新)下,别人老环境不报错。

错误示例

一个错误示例,子项目引用了父项目,子项目parent标签处报错如下:
Multiple annotations found at this line:
- maven-enforcer-plugin (goal "enforce") is ignored by m2e.
- Plugin execution not covered by lifecycle configuration: org.codehaus.mojo:aspectj-maven-plugin:1.3.1:compile (execution: 
 default, phase: compile)
 

解决办法

官网给出解释及解决办法:http://wiki.eclipse.org/M2E_plugin_execution_not_covered

这里有人说下面这样也可以解决, 即 标签外再套一个 标签,我试验是成功的:
http://stackoverflow.com/questions/6352208/how-to-solve-plugin-execution-not-covered-by-lifecycle-configuration-for-sprin

   
       
            ...
            ...
                  ....
       

   


但是有时候父项目pom不能被修改,可用官网最后给出的解决办法:
Window-Perferences-Maven-Lifecycle Mapping

保存如下内容:
"1.0" encoding="UTF-8"?>

   
    
       
           
                org.codehaus.mojo
                aspectj-maven-plugin
               
                    compile
               

                [1.3,)
           

            <action>
               
            action>
       

        
   


记得点击 ”Reload workspace lifecycle mappings metadata“按钮

问题解决。

(完)
顶 3 踩 32
阅读(584) | 评论(0) | 转发(0) |
给主人留下些什么吧!~~
评论热议
请登录后评论。

登录 注册